Mitsubishi Lancer Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hello, I recently purchased a 2011 Evo X MR, and not even 12 hours after purchase, the car's transmission gave out in the middle of an intersection. After waiting a few minutes I was able to maneuver it back to my driveway and park it. I have no reverse gear and all drive gears feel sluggish, omegle xender with no real way to test which work and don't. I've read that these are the symptoms of a Shift Fork Magnet that's gone loose or fallen off, but I thought I'd come and see if anyone else had experienced this before I go back to the dealership and have them repair it as it should be covered under P.A. 99-768.
 

·
Registered
Joined
·
7,776 Posts
Yes, get it back to the selling (warrantying) dealer. Dealers only replace the TC-SST gearboxes, they don't attempt to repair them.
 

·
Registered
Joined
·
345 Posts
Man, that's not good. Hopefully they'll take care of it, and not try to blame you for driving the car like you stole it right after you bought it.
 

·
Registered
Joined
·
1 Posts
Got the "Transmission Service Required" warning indicator this morning when I started it up. Bone stock 2010 MRT 11K miles. It was 73 deg outside so ambient temperature wasn't a problem.
Made an appointment at the dealership. I have my fingers crossed that it's not a major issue. Never noticed any problems or strange noises before this....well except the usual slight-delay-from-a-dead-stop issue that all SST's supposedly have. Will report back with updates after my service appointment.
 
1 - 4 of 4 Posts
Top