Mitsubishi Lancer Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So I Installed a pair of Vland tail lights on my 2011 Evo X. LEDs. Has what looks like a load resister on each tail light I guess for LEDs ? turn signals and brake.

https://www.vland-carlamp.com/LED_Tail_Lights_For_20082017_Mitsubishi_Lancer_evo_x_Smoked/p4995994_17774418.aspx

Noticed now that the reverse camera only stays on for about 5 seconds. Suspect this is the issue. I have a Fosgate OEM head unit too. I've heard that splicing a 50 watt 3 ohm load resister into the reverse leads may solve the problem. Anyone with a similar problem and fix?
 

·
Registered
Joined
·
314 Posts
You have answered yourself the question. Add the 50w 3 ohms resistor (in parallel) to the reverse lamp and you will be good.
No splicing needed, just clamping.
 

·
Registered
Joined
·
314 Posts
By the way. Would recommend to take an 8 ohms, as 3 ohms will give you a 48W at the resistance. will get Pretty hot.
This is the type you can get as it’s a plug and play.
US $8.00 20% Off | 2 PCS 7440 W215W T20 Canbus Error Free Resistor LED Decoder Warning Error Canceller For LED Turn Signal Bulb 50W
https://a.aliexpress.com/LWaYbVUU

Make sure you get a resistance between 8-15 ohms, else it won’t work. (Bought one similar to this, but they had 20ohms in 2x10 ohm serial setup, which didn’t work)
 

·
Registered
Joined
·
314 Posts
By the way. Would recommend to take an 8 ohms, as 3 ohms will give you a 48W at the resistance. will get Pretty hot.
This is the type you can get as it’s a plug and play.
US $8.00 20% Off | 2 PCS 7440 W215W T20 Canbus Error Free Resistor LED Decoder Warning Error Canceller For LED Turn Signal Bulb 50W
https://a.aliexpress.com/LWaYbVUU

Make sure you get a resistance between 8-15 ohms, else it won’t work. (Bought one similar to this, but they had 20ohms in 2x10 ohm serial setup, which didn’t work. See picture attached)
 

Attachments

1 - 4 of 4 Posts
Top