Mitsubishi Lancer Evolution Forum banner
1 - 20 of 62 Posts

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #1 ·
I woke up this mornin and went to go to walmart but my car wouldn't engage into gear. I blew my stock clutch out a while ago and side than has been replaced by a competition clutches stage 3 clutch with a MAP lightweight flywheel. I am on stock CMC still not sure if that would cause it to not engage or what. When I tried to engage it the RPMs drop and with a lot of force when I'm able to get it into gear the car just shuts off.. Anyone else had this problem and what was wrong. Btw car has around 9-10k on it since the clutch was installed.
 

·
[Local Team Member], aka JDAVID-EVO X
Joined
·
16,650 Posts
have you replaced the uderhood bushings?? If you have, double check them. In cold wheather our trannies get a lil crazy and hard to engage into gear.
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #4 ·
Yes I have replaced my underhood bushings. Along with my base bushings and short throw
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #6 ·
But why would that cause the motor to die out? I'm going to check them when I get home. Make sure everything is stil together
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #7 ·
Checked the underhood bushings there all still in place and held on. Any other ideas?
 

·
Registered
Joined
·
8,771 Posts
I had the same exact thing happen to me just 2 weeks before my rubber clutch line disengaged and left me with what I thought was a blown CMC... The synchros work so well on these cars you won't get a grind when shifting without the clutch, you only get grinds when everything is working properly...go figure!
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #10 ·
What was the fix silcone?
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #12 ·
Oh I'll try to inspect it to see if it's fallen out
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #15 ·
Yes. I forgot to mention while the car is off everything is as smooth as it was from day 1 completely different story when it's running though. I was told to look at the slave?
 

·
Premium Member
Joined
·
6,689 Posts
Yes. I forgot to mention while the car is off everything is as smooth as it was from day 1 completely different story when it's running though. I was told to look at the slave?
yeah look at the cmc, its by the clutch pedal if its leaking that's your problem. If its not, check your clutch line. Check your brake fluid level, it should be on the max or something like that, if you lost any fluid you will tell immediately that you have a leak somewhere.
 

·
Premium Member
Joined
·
6,689 Posts
If everything looks fine, then your pressure plate must be messed up. I had it with my spec clutch, clutch was freaking new and i coudlnt get it into gears when the car was turn on. Also, you said it was competition clutch i believe Jeremy said they made a new design for the clutch i dont know if you got that new design.
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #18 ·
Yeah I dunno Clutch isn't even a year old it's got like 9k on it. Everything is supposed k be brand new when I had it installed, although it wouldn't surprise me if the shop I had install it put my OEM one back in. I'll check my fluid Levels and everything tomorrow. Frustrating as hell......
 

·
Premium Member
Joined
·
6,689 Posts
Yeah I dunno Clutch isn't even a year old it's got like 9k on it. Everything is supposed k be brand new when I had it installed, although it wouldn't surprise me if the shop I had install it put my OEM one back in. I'll check my fluid Levels and everything tomorrow. Frustrating as hell......
Yeah i been there, my pressure plate on my spec clutch fail with 300 miles so be happy lol But there a lot of factors, installation etc that can mess up a clutch. Check for the cmc and clutch lines and fluid, let me know if you need any help.
 

·
[CCEvo VP]
Joined
·
1,386 Posts
Discussion Starter · #20 ·
Yep will post my findings tomorrow
 
1 - 20 of 62 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top