Mitsubishi Lancer Evolution Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone. Just bought a 2011 Evo. Previously owned a 17’ WRX. Loved that car but it’s time for a new project and a more capable platform IMO. I don’t know much about the Evo but so far I’m loving the car.

Right now I’m trying to figure out what the previous owner has done to the car (stop me if you’ve heard that one before.)
The car came with what looks like a down pipe. It has a test pipe and cat back. Upgraded clutch which is stiff as a mother, GFB BOV, Grimmspeed EBCS, upgraded top intercooler piping, possibly upgraded intercooler and lower intercooler piping, not really sure.

Two things I ordered right away are fuel pump relays, a wideband AFR and a boost gauge because I have no idea how the car is running. It idles fine, drives fine, but sometimes takes a few more cranks than normal to start. But it does start every time.

THE UGLY. Car is throwing a P0017 code. And from what I’ve researched so far on here is that it could be a number of things. The sensor, exhaust oil control solenoid, or the chain itself. I figured if it was the chain I’d at least hear something going on in the engine or it would idle rough or SOMETHING like that. Again, I don’t know.

I’ll be curious to hear everyone’s thoughts on the car and how much work I have ahead of me lol. But I look forward to meeting you all online and maybe offline too if anyone is on the southwest coast of Florida!
 

·
Registered
2010 Mitsubishi Lancer Evo X GSR
Joined
·
4 Posts
Welcome. I'm coming from the subie word as well (still have one more left) Im located in Maryland, I'm a parts dealer and installer mainly for Subaru's but in May I traded with a business partner one of my built Subaru's for a 2010 Evo X GSR so I'm slowly learning the platform and offering some parts service and installs on them now too. Just recently got a dealer account with MAPerformance and they have been real helpful.
 
1 - 4 of 4 Posts
Top